Page 1 of 1

Package configuration problem

Posted: Fri Nov 06, 2020 1:38 pm
by pistoleta
We have installed the plugin using the package manager as the documentation says but we have a problem.
Once the package is installed the manifest.json keeps pointing the original path of the asset in the filesystem, in my case:
"com.hovelhouse.cloudkit": "file:/Users/juan/Downloads/CloudKit",

I don't know if this is how is supposed to work but all the other packages point their versions instead of the asset location. This wouldn't be a problem if I were developing alone but we are using Unity Collab and as you might know it synchronizes the packages following the manifest.json and the packages in the respective folders. So when I sync my coworkers unity is trying to find that path that doesn't exist in their computers.

What we want is simply the package to behave like the rest, if one of us updates the asset from the package manager the other should get also the new versions but for the moment it doesn't seem possible.

Are we doing something wrong?

Thanks

PS: you mentioned in the asset store paid users get the plugin source code, we purchased today. How do we get it?

Re: Package configuration problem

Posted: Fri Nov 06, 2020 2:01 pm
by pistoleta
Okay I tried dragging the asset to the package folder directly, where the manifest.json file is and it worked, the asset appeared in the package manager window as installed magically too.
Now manifest.json doesn't make any reference to the CloudKit asset, so im not sure if this is good.
I will see how this updates to the other Collab members.

Re: Package configuration problem

Posted: Mon Nov 09, 2020 2:04 pm
by admin
Thank you for the report. Please keep us posted on how the package behaves with Unity Collab and whether anything needs to be addressed there. We will look into whether improvements can be made to the installation process or documentation. Unfortunately, the Unity asset store does not have very good compatibility with the new package management system and our options are limited.

As for the full plugin source. It can be found at this git repository. https://github.com/nullObjectPtr/hovelh ... udkit-full
The repository is public and no credentials are needed to access it at this moment, but this may change at a later date.

Re: Package configuration problem

Posted: Mon Nov 16, 2020 6:49 pm
by pistoleta
yes, seems simply dragging to the package folder using Finder as you suggest in the documentation works well. No problems so far.